Hello Guest

The bot tells me to "slow down" !

  • 3 Replies
  • 113 Views
*

parisd

  • **
  • 12
  • +0/-0
    • View Profile
The bot tells me to "slow down" !
« on: October 30, 2020, 07:03:51 am »
Who is sending me that message the dicebot itself or Primedice?

Off course I cannot slow down, I dont control the speed of the Dicebot. So why do I get this kind of message


*

Seuntjie

  • *****
  • 534
  • +14/-2
    • View Profile
Re: The bot tells me to "slow down" !
« Reply #1 on: October 30, 2020, 07:09:26 am »
Who is sending me that message the dicebot itself or Primedice?

PrimeDice is sending the message, DiceBot just displays it to you.

Off course I cannot slow down, I dont control the speed of the Dicebot. So why do I get this kind of message

Yes you can. Go to the advanced mode -> advanced bet settings. Enable the bet speed setting and set it to something that works.

You're getting this message because PrimeDice and Stake has been under strain recently (long running DDOS attack according to them) and have implemented rate limits. Meaning you can only do x amount of API calls to the site every second before the site rejects your requests. These limits aren't coded into dicebot because they keep changing the whole time. You can reduce the amount of times you get this error by not having the site open in your browser and/or setting a bot speed. from what I've heard, 1 bet per second or slightly slower should be fine.

PS. The bot speed setting is applied regardless of which settings mode you're using.

*

parisd

  • **
  • 12
  • +0/-0
    • View Profile
Re: The bot tells me to "slow down" !
« Reply #2 on: November 03, 2020, 09:47:55 am »
Is the speed of betting the only Advanced mode setting that remains valid when in programmer mode or there are other Advanced Mode settings that are in effect when we are in programmer mode?

I have never checked before the Advanced mode to make sure there are no conflicting setting that could affect the script in programmer mode.

Who is sending me that message the dicebot itself or Primedice?

PrimeDice is sending the message, DiceBot just displays it to you.

Off course I cannot slow down, I dont control the speed of the Dicebot. So why do I get this kind of message

Yes you can. Go to the advanced mode -> advanced bet settings. Enable the bet speed setting and set it to something that works.

You're getting this message because PrimeDice and Stake has been under strain recently (long running DDOS attack according to them) and have implemented rate limits. Meaning you can only do x amount of API calls to the site every second before the site rejects your requests. These limits aren't coded into dicebot because they keep changing the whole time. You can reduce the amount of times you get this error by not having the site open in your browser and/or setting a bot speed. from what I've heard, 1 bet per second or slightly slower should be fine.

PS. The bot speed setting is applied regardless of which settings mode you're using.

*

Seuntjie

  • *****
  • 534
  • +14/-2
    • View Profile
Re: The bot tells me to "slow down" !
« Reply #3 on: November 03, 2020, 09:55:07 am »
Depends on what you do in your script.

As described in the template for the programmer mode and the tutorials:

Code: [Select]
enablezz=false --set to true to use high/low switching
--settings from advanced mode

enablesrc=false --set to true to use stop/reset conditions
--settings from advanced mode

If you use the built in functions for martingale(),labouchere() etc they will also use the relevant advanced mode settings.

If you don't use any of those functions and the two values mentioned above are set to false, the betting speed is the only setting from the advanced mode that it used.